服务热线: 0769-23015555

服务器租用,服务器托管,云主机,IDC机房,云服务器,IDC提供商,唯一网络

热门: 服务器租用| 服务器托管| 云安全| 机柜大带宽| 网络安全
首页>帮助中心>运维资讯>(运维预警)Apache Struts 2 远程代码执行漏洞
关注企业中心微信公众号
微信公众号:唯一网络
我们的微信公众号
  • 1

需要帮助?

服务热线:
0769-23015555 在线咨询

(运维预警)Apache Struts 2 远程代码执行漏洞

发布时间: 2016/03/17    

  Apache Struts 2是世界上最流行的Java Web服务器框架之一。然而不幸的是,有安全研究员在Struts 2上发现了一枚远程代码执行漏洞。 目前Apache官方已发布公告,该漏洞危险级别为高危。

  FreeBuf百科:Struts 2Struts 2是Struts的下一代产品,是在 struts 1和WebWork的技术基础上进行了合并的全新的Struts 2框架。其全新的Struts 2的体系结构与Struts 1的体系结构差别巨大。Struts 2以WebWork为核心,采用拦截器的机制来处理用户的请求,这样的设计也使得业务逻辑控制器能够与 ServletAPI完全脱离开,所以Struts 2可以理解为WebWork的更新产品。虽然从Struts 1到Struts 2有着太大的变化,但是相对于WebWork,Struts 2的变化很小。

  今天有安全研究员在Struts 2上发现了一个严重的远程代码执行漏洞(CVE-2016-0785),所以Struts 2的开发者和用户都应该知晓这枚漏洞,以防被不法企图者恶意利用。

  受影响的Struts 2版本Struts 2.0.0 – Struts Struts 2.3.24.1

  修复建议当重分配传入Struts标签属性的参数时,总是进行验证

  建议用户将Struts升级至 2.3.25版本。

        服务器租用/服务器托管最具实力IDC提供商!十年品牌保障 - 唯一网络!
        转载请注明:唯一网络http://www.wy.cn/